I got this error when trying to build via command line:

ld: file is universal (4 slices) but does not contain a(n) armv7s slice: /Users/../Framework/Realm.framework/Realm file '/Users/../Framework/Realm.framework/Realm' for architecture armv7s

Here is the command line code:

xcodebuild -scheme $SCHEME ONLY_ACTIVE_ARCH=NO ARCHS="armv7 armv7s x86_64" PROVISIONING_PROFILE=$provi PRODUCT_NAME=$AP_NAME ASSETCATALOG_COMPILER_APPICON_NAME=$AppIcon archive -archivePath ../build/$AP_NAME.xcarchive

Does the Realm framework supports armv7s?

Related posts

Recent Viewed