I have Android App that uses support library versions 27.1.2. I want to consume a library written using Android X (api 28).

There are few issues with name spacing of the library versions.

Example ...

The library has a Dialog that I want to use with the api

Dialog.show(androidx.fragment.app.FragmentActivity activity);

However all my activities are using

android.support.v4.app.FragmentActivity

and the compiler does not like this.

Currently it is not an option to upgrade my project to latest version (cost of regression testing, and office politics), so please no upgrade answers (even though I would love to do this upgrade).

Is there a way to resolve this incompatibility issue?

Thanks in advance.

Related posts

Recent Viewed